29 de marzo de 2020
 
Publicado 03/03/2020 13:15:38CET

Una vulnerabilidad crítica afecta a decenas de móviles con procesadores de MediaTek

Procesador MediaTek Helio P90
Procesador MediaTek Helio P90 - MEDIATEK - Archivo

   MADRID, 3 Mar. (Portaltic/EP) -

   Google ha descubierto una vulnerabilidad crítica presente en decenas de modelos de procesadores para 'smartphones' y tabletas de la taiwanesa MediaTek que los 'hackers' ha explotado activamente para conseguir permisos sensibles en el dispositivo.

   Este fallo de seguridad, conocido como CVE-2020-0069, ha aparecido en el boletín de seguridad de Android de marzo, donde Google lo valora como de "severidad alta", pero lleva existiendo al menos desde abril de 2019, según se ha reportado en los foros de XDA Developers.

   La vulnerabilidad se encuentra presente en los 'drivers' que conforman el 'firmware' de los procesadores MediaTek, en concreto los que gestionan la cola de comandos del chip, según Google.

   Para explotarla, según el usuario de XDA que descubrió el fallo, solamente este necesario ejecutar un 'script' con el que es posible obtener un acceso privilegiado a los permisos del 'kernel' de Linux que gestiona el control de acceso a los procesos, estableciendo una configuración altamente permisiva.

Cualquier aplicación del dispositivo es capaz de copiar y ejecutar el 'script' malicioso, obteniendo así los permisos de raíz o 'root' sensibles y evitando los mecanismos de seguridad de Android, quedando así expuesto a ataques de 'ransomware'.

   El problema de seguridad afecta, como recoge XDA, al menos a 24 modelos de procesadores de MediaTek con arquitectura de 64 bits de todas las gamas, incluyendo varios chips de la familia Helio: P10, P20 y P30, A22, P22, P23, P35, P60, P90, X10, X20 y X30.

   Los procesadores vulnerables se encuentran presentes en al menos 93 dispositivos, entre 'smartphones' y tabletas, de marcas como Acer, Alcatel, Amazon (varias tabletas Fire), Asus, Blu, BQ, Huawei, Lenovo, LG, Meizu, Nokia, Oppo, Realme, Sony, Wiko, Xiaomi y ZTE, entre otras.

   El fallo puede explotarse en los dispositivos con las versión 3.18, 4.4, 4.9, or 4.14 del Kernel de Linux que funcionen en los sistemas operativos Android 7 Nougat, 8 Oreo o 9 Pie. No obstante, el sistema Android 10 no está afectado debido a su configuración de permisos.

   MediaTek distribuyó a las marcas el año pasado un parche de seguridad que soluciona la vulnerabilidad, y algunos fabricantes como Amazon ya han hecho llegar el parche a sus dispositivos, aunque según XDA, docenas de ellos aún siguen siendo vulnerables, en especial los que emplean versiones antiguas de Android.

Contador

Para leer más